ADVrider

Go Back   ADVrider > Gear > Vendors
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-28-2012, 06:27 PM   #1
kma_jg OP
Adventurer
 
Joined: Mar 2012
Oddometer: 15
Issues with Motostorm.it and the Scala Rider G9

I have a lot of things (bad) to say about these two products right now, but out of politeness, I won't express all of them.

Bought the Scala Rider G9 power set from Motostorm.it in October. It took about three weeks to arrive in Melbourne. Not great.
Then I used the G9 for almost a week before one of the units began with its issues. Cardo couldn't help, shipped it back to Italy ($70 on me for that). When it arrived there, I had to explain everything what was wrong twice. It took them three weeks to get a replacement unit which is freakin' absurd. How long does it take to see it is farked...

I used the double sided tape to mount it on the side of the helmet and because I had to ship everything back (not just the suspect unit) I had to take the mounts off as well. Double sided tape can't be reused again. Was told that they would replace those. They didn't and now I have to go out and find that stuff somewhere to use.

Trying to connect the "new" unit to my PC via this "Updater" and the Community webpage and it is not recognized. Tried everything. NO luck getting the unit added to my profile.

Warning: The customer service from Motostorm.it sucks. They do not reply to your emails. Takes ages to do anything with the faulty stuff and now the unit that got replaced is giving issues already.

Maybe somebody had beter experiece, but I am not a happy camper.

On the G9: Biggest POS I could ever buy. Radio reception is better than the old Q2, but half of the stations have noise on them from interference. I think by increasing the reception, they are too sensitive for other interference.
The Voice commands/recognitions sucks as well. It doesn't recognize you speak unless you scream. Sound quality/loudness is not too bad. Voice instructions via Bluetooth GPS is also bad and delayed.

Rant over.
kma_jg is offline   Reply With Quote
Old 01-04-2013, 09:53 AM   #2
motostorm
n00b
 
Joined: Jan 2013
Oddometer: 2
Dear Johan,
usually not we take part in the discussions that concern us, both in case positive or negative, but in this case
does not seem correct what you are saying.

After your order we sent immediately the first G9 Powerset, you ordered it the 6th of November and we sent it the same day, this is your FedEx tracking: 794008708596.


We think the cause of all your problem is you.
You have changed the system with wrong settings that compromised the firmware, and you have given the same name to both devices that's not that is not allowed causing a problem.
However we told you to return the box (nobody told you to send back the adhesive bases that could have been used more, enough to unscrew the audio kit), you have to understand that shipment from Australia is very expensive and we can't charge it, but we would have supported spending return shipping.

Now it's very strange that 2 times you get a defective device and as we told you we think the problem was caused by you.

Still wanting to solve the problem we can give you a full refund, return shipping will be your responsibility.

Filippo Quadrelli - Motostorm.it
motostorm is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 02:47 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014