ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-08-2013, 08:47 PM   #1
DefiantMenace OP
n00b
 
Joined: Jan 2013
Oddometer: 1
A 93 xr650l with an Issue :(

Hello Everyone!

I hate to come to a forum just to pick the brains of its members, but I am in need of help and I have helped others a lot in my time.....so I figured I would see if anyone here could lend a hand. Also if your in phoenix I will gladly return the favor.

I bought 93 xr650l, which was supposidly a good running bike. It does run good however when you stop, or the bike idles for a few minutes it will just die(not slow like perhaps a fuel issue, it just dies instantly). Down the street it generally does pretty good. Like I said its a 93 with 8500 miles and is all stock.

I have been doing research online here is what I have already done.

1 replaced cdi
2 checked wiring harness while running, moved wires around looking for bad contacts
3 cleaned up ground contact under seat
4 took apart and cleaned switches
5 jumped out safety switches by grounding the clutch safety
6 fixed a vaccum leak
7 checked tank for vapor lock issue
8 stator is fine as the battery is staying charged
9 replaced spark plug and cleaned and checked all coil contacts.

I have basically ran though everything I could think of as well as what I could find online. The bike also passed emissions with no issues, I hate to part this thing out just because I cant find the answer to this problem. I was thinking it might be the coil???

If anyone has ANY ideas I would be very greatful. I just dont want to spend any more money throwing parts at this thing.
THANK YOU

I tried posting this at ThumperTalk but the people there were as lost as I was unfortunatly :( Maybe someone here will have had this issue before.
DefiantMenace is offline   Reply With Quote
Old 01-09-2013, 06:04 AM   #2
JWhitmore44
pistolero
 
JWhitmore44's Avatar
 
Joined: Aug 2006
Location: NW Kansas
Oddometer: 1,560
Does it start right back up after it dies? What happens if you turn the idle up a little? Will it stay running then, it doesn't need to idle like a Harley :) How's your plug look, is it black, too rich? I would also check the valves and do a compression check.

And to check in with the experts come on over to http://www.advrider.com/forums/showt...4834&page=3426
__________________
84 Honda Goldwing (GL1200)
03 XR650L
JWhitmore44 is offline   Reply With Quote
Old 01-09-2013, 07:06 AM   #3
mcma111
Beastly Adventurer
 
mcma111's Avatar
 
Joined: Jul 2007
Location: San Francisco,Ca.
Oddometer: 10,683
Have you checked the valve clearance?
__________________
Steve in SF

BMW's
58 R26
79 R100s
91 R100gs

87 Harley FXRS-SP ~ 06 KTM 625 SMC ~ 72 Honda CB750/915cc ~ 92 XR600/654cc ~ 95 XR650l/675cc ~ 03 CRF450r ~ 05 CRF450x ~ 02 XR650l/675cc ~ 86 YZ490 ~ 93 YZ80 ~ 93 XR650l Project
mcma111 is offline   Reply With Quote
Old 01-09-2013, 08:22 AM   #4
kubiak
Beastly Adventurer
 
Joined: Nov 2007
Location: madera california
Oddometer: 4,809
Quote:
Originally Posted by mcma111 View Post
have you checked the valve clearance?
+1
kubiak is offline   Reply With Quote
Old 01-09-2013, 09:24 AM   #5
AZ TOM
Beastly Adventurer
 
Joined: Oct 2008
Location: Prescott AZ
Oddometer: 3,460
Kick stand switch?
AZ TOM is offline   Reply With Quote
Old 01-09-2013, 09:37 AM   #6
mcma111
Beastly Adventurer
 
mcma111's Avatar
 
Joined: Jul 2007
Location: San Francisco,Ca.
Oddometer: 10,683
Quote:
Originally Posted by AZ TOM View Post

Kick stand switch?

5 jumped out safety switches by grounding the clutch safety
__________________
Steve in SF

BMW's
58 R26
79 R100s
91 R100gs

87 Harley FXRS-SP ~ 06 KTM 625 SMC ~ 72 Honda CB750/915cc ~ 92 XR600/654cc ~ 95 XR650l/675cc ~ 03 CRF450r ~ 05 CRF450x ~ 02 XR650l/675cc ~ 86 YZ490 ~ 93 YZ80 ~ 93 XR650l Project
mcma111 is offline   Reply With Quote
Old 01-09-2013, 10:22 AM   #7
AZ TOM
Beastly Adventurer
 
Joined: Oct 2008
Location: Prescott AZ
Oddometer: 3,460
Quote:
Originally Posted by mcma111 View Post
5 jumped out safety switches by grounding the clutch safety
Would take a second look at that. He said just quits, no sputtering or lead up?
AZ TOM is offline   Reply With Quote
Old 01-09-2013, 10:54 AM   #8
mcma111
Beastly Adventurer
 
mcma111's Avatar
 
Joined: Jul 2007
Location: San Francisco,Ca.
Oddometer: 10,683
What happens if you put the kickstand down when engine is running in gear. Instant kill.
__________________
Steve in SF

BMW's
58 R26
79 R100s
91 R100gs

87 Harley FXRS-SP ~ 06 KTM 625 SMC ~ 72 Honda CB750/915cc ~ 92 XR600/654cc ~ 95 XR650l/675cc ~ 03 CRF450r ~ 05 CRF450x ~ 02 XR650l/675cc ~ 86 YZ490 ~ 93 YZ80 ~ 93 XR650l Project
mcma111 is offline   Reply With Quote
Old 01-09-2013, 10:55 AM   #9
Rot Box
Gnarly Adventurer
 
Joined: Oct 2010
Location: Northern Utah
Oddometer: 189
My money (or lack thereof) is on a tight valve(s) or possibly a burnt valve. Does it start good, idle good and idle good when up to operating temperature? If the answer is no on any of these I would clean the pilot circuit in the carburetor and double check that the pilot circuit is jetted properly. I wouldn't rule out electronics but I think you'd notice it while riding as well.
__________________
94 ATK605DSES - 1984 CR500R - 1981 XL500S
Rot Box is offline   Reply With Quote
Old 01-09-2013, 11:49 AM   #10
AZ TOM
Beastly Adventurer
 
Joined: Oct 2008
Location: Prescott AZ
Oddometer: 3,460
Probably remove carb & clean all jets. Remove & check the rubber diaphram right side near the top under cap. They sometimes get old & develop cracks & cause lots of problems, this I know
AZ TOM is offline   Reply With Quote
Old 01-09-2013, 03:21 PM   #11
kubiak
Beastly Adventurer
 
Joined: Nov 2007
Location: madera california
Oddometer: 4,809
pilot jet may be too small and cause a sneeze or dies at idle or maybe the stock one is a little clogged? its nice to go up one size if you have the stock pilot jet anyway. you can also check if turning the fuel screw out all the way helps with the problem.
kubiak is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:31 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014