ADVrider

Go Back   ADVrider > Gear > Equipment
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-10-2013, 02:08 AM   #1
Burra Boy OP
Adventurer
 
Joined: Dec 2006
Oddometer: 54
Vapor mode button doesn't work

Hey out there

As the title suggests, my vapor speedo/ tacho has failed to proceed. I cannot change mode so can't reset trip, check odometer, etc etc.

Emailed Vapor who suggested I buy a new one coz mine is 3 years old...

I may end up doing that but I'm hopeful that someone has had a similar problem and found how to fix it. I'm a poor old pensioner, after all

I've sprayed it with cleaners, lubricants and high pressure air with no luck. I'm assuming there's a bad contact under the button but don't want to rip it apart without some guidance.

Anyone?

Cheers
Burra Boy is offline   Reply With Quote
Old 01-10-2013, 07:53 PM   #2
Burra Boy OP
Adventurer
 
Joined: Dec 2006
Oddometer: 54
Anyone?????
Burra Boy is offline   Reply With Quote
Old 01-11-2013, 06:40 AM   #3
bracky72
Studly Adventurer
 
Joined: Feb 2011
Location: Charles Town, West Virginia
Oddometer: 898
Dip the portion with the button in isopropyl alcohol. Work the button while submerged. Allow it to completely dry.
bracky72 is offline   Reply With Quote
Old 01-11-2013, 08:57 AM   #4
G19Tony
Gnarly Adventurer
 
G19Tony's Avatar
 
Joined: Oct 2011
Location: KLAS
Oddometer: 394
If you might have to get a new one anyway... The alcohol trick is worth a shot.
__________________
Honda CT70, Hodaka Dirt Squirt, Kawasaki Versys, Suzuki TU250,
Honda CRF250L, Honda CRF80F, Honda CRF230F, Honda CL70.

Nothing's too cruel if it's funny enough.
G19Tony is offline   Reply With Quote
Old 01-12-2013, 03:30 PM   #5
Burra Boy OP
Adventurer
 
Joined: Dec 2006
Oddometer: 54
Thanks guys. I'll give that a shot and see what happens. I'll let you know if it worked
Burra Boy is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 01:40 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014