ADVrider

Go Back   ADVrider > Bikes > Orange Crush > Crazy-Awesome almost Dakar racers (950/990cc)
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-30-2014, 05:17 AM   #1
wheeler23 OP
Adventurer
 
wheeler23's Avatar
 
Joined: May 2013
Location: Corn Field County Indiana
Oddometer: 78
990 FI light and no instrument readings?

Have a 2013 990. Today I started the bike up and shut it back off real quick because I forgot to lock the top box. Started it back up and headed off and realized I haad no instrument panel readingds and no tach????? Got to work and shut it off restarted and same..... plus now the FI light stays on when I remove the key????? Any Ideas????
__________________
Ride it like you stole it!!!!!

KTM 990 Baja Edition, KTM 250SXF, KTM 150XC
wheeler23 is offline   Reply With Quote
Old 04-30-2014, 07:51 AM   #2
Martin106
PatagoniaNomad
 
Martin106's Avatar
 
Joined: Jun 2013
Location: Buenos Aires, Argentina
Oddometer: 37
Thumb

Quote:
Originally Posted by wheeler23 View Post
Have a 2013 990. Today I started the bike up and shut it back off real quick because I forgot to lock the top box. Started it back up and headed off and realized I haad no instrument panel readingds and no tach????? Got to work and shut it off restarted and same..... plus now the FI light stays on when I remove the key????? Any Ideas????
There is no reading at all? No tach and no speed? No temperature? It happened to me two weeks ago. The display died. Had to put a new one.
First check the fuses. I think its the third from the left. The only good thing is that the bike continues to work with no problem. The bad, it`s expensive and has to be ordered from Austria with the correct millage.
Hope is just the fuse!!
Martin106 is offline   Reply With Quote
Old 04-30-2014, 08:29 AM   #3
wheeler23 OP
Adventurer
 
wheeler23's Avatar
 
Joined: May 2013
Location: Corn Field County Indiana
Oddometer: 78
Quote:
Originally Posted by Martin106 View Post
There is no reading at all? No tach and no speed? No temperature? It happened to me two weeks ago. The display died. Had to put a new one.
First check the fuses. I think its the third from the left. The only good thing is that the bike continues to work with no problem. The bad, it`s expensive and has to be ordered from Austria with the correct millage.
Hope is just the fuse!!
Manual says it may be fuse acc#1 (clock).... I'll try that?
__________________
Ride it like you stole it!!!!!

KTM 990 Baja Edition, KTM 250SXF, KTM 150XC
wheeler23 is offline   Reply With Quote
Old 04-30-2014, 08:40 AM   #4
Martin106
PatagoniaNomad
 
Martin106's Avatar
 
Joined: Jun 2013
Location: Buenos Aires, Argentina
Oddometer: 37
Thumb

Quote:
Originally Posted by wheeler23 View Post
Manual says it may be fuse acc#1 (clock).... I'll try that?
Yes. Hope thats the problem.
Martin106 is offline   Reply With Quote
Old 04-30-2014, 08:42 AM   #5
wheeler23 OP
Adventurer
 
wheeler23's Avatar
 
Joined: May 2013
Location: Corn Field County Indiana
Oddometer: 78
Quote:
Originally Posted by Martin106 View Post
Yes. Hope thats the problem.
Just pulled the fuse (it was good), put it back in, and problem went away!!!!
__________________
Ride it like you stole it!!!!!

KTM 990 Baja Edition, KTM 250SXF, KTM 150XC
wheeler23 is offline   Reply With Quote
Old 04-30-2014, 09:03 AM   #6
Martin106
PatagoniaNomad
 
Martin106's Avatar
 
Joined: Jun 2013
Location: Buenos Aires, Argentina
Oddometer: 37
Laugh

Quote:
Originally Posted by wheeler23 View Post
Just pulled the fuse (it was good), put it back in, and problem went away!!!!
Good! I think you should get a contact cleaner spray and clean it really good.
You just saved yourself $450
Martin106 is offline   Reply With Quote
Old 04-30-2014, 09:08 AM   #7
wheeler23 OP
Adventurer
 
wheeler23's Avatar
 
Joined: May 2013
Location: Corn Field County Indiana
Oddometer: 78
Quote:
Originally Posted by Martin106 View Post
Good! I think you should get a contact cleaner spray and clean it really good.
You just saved yourself $450
Thanks!! I'll try that. If it had been bad I hope it would have been covered under warranty. Bike is less than a year old.......
__________________
Ride it like you stole it!!!!!

KTM 990 Baja Edition, KTM 250SXF, KTM 150XC
wheeler23 is offline   Reply With Quote
Old 04-30-2014, 09:13 AM   #8
Martin106
PatagoniaNomad
 
Martin106's Avatar
 
Joined: Jun 2013
Location: Buenos Aires, Argentina
Oddometer: 37
Quote:
Originally Posted by wheeler23 View Post
Thanks!! I'll try that. If it had been bad I hope it would have been covered under warranty. Bike is less than a year old.......
It should have! It happened to me in Bolivia. I took the bike to the official KTM dealer en La Paz and he screw it up. Its a long story, but at the end, I left with no display... (yes, official KTM dealer)
Anyway! glad you have it back!
Martin106 is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 07:18 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014