ADVrider

Go Back   ADVrider > Riding > Regional forums > Southeast, The Lair of the Dragon - The Blue Ridge and Smoky Mountains
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-10-2013, 08:51 AM   #1
ronandkat OP
Gnarly Adventurer
 
Joined: Sep 2007
Location: Greensboro NC
Oddometer: 147
Buell Service in TRIAD area of NC..Urgent

Id like to get some work done on my bike in 2 weeks while im on a family vacation. I have read rave reviews on badweb of a great shop doing service on buells I THINK in the highpoint area, however I do not remember the guys name, the shops name, etc.. thus I cannot search it on the internet? Or any other recommended shopes within an hour or so of Greensboro? Tried Gsbo Harley Davidson, and wasn't overly impressed?
Any Help Greatly Appreciated!
ronandkat is offline   Reply With Quote
Old 04-10-2013, 09:51 AM   #2
KingJarhead
Beastly Adventurer
 
KingJarhead's Avatar
 
Joined: Apr 2011
Location: Not at Work...Pinnacle, NC
Oddometer: 1,901
If I need a part or advice on repair I go to Clemmons Motorcycle.
http://www.clemmonsmotorcycles.com/index.html

I believe he was the first "Authorized" Buell mechanic in NC when he worked for a Harley Shop. Not sure but I do remember hearing that. I do my own wrenching but if needed I would go to him. Others might disagree but it is my experience.
I know some from a local Buell Facebook page ( https://www.facebook.com/groups/ncscbuells/) bring their Buells to
Cycle Sop LLC (336) 293-4060
__________________
--------------------------------------------
"There are 2 types of motorcycle riders, those that have wrecked and those that will wreck" - My Dad
KingJarhead is offline   Reply With Quote
Old 04-10-2013, 10:08 AM   #3
ronandkat OP
Gnarly Adventurer
 
Joined: Sep 2007
Location: Greensboro NC
Oddometer: 147
Thanks!

I have a lifter pecking away occasionally, and a ping / peck in the top in the 2600-3000 rpm range at 1/8 throttle openings or so. Goes away if I give it more gas, or less gas and its definitely a top end sound.. Just want to get it checked, its been doing it for 9 months now and hasn't gotten any worse, or better and performance hasn't suffered but I have only put about 900 miles on it in that time. Started after I did an oil change and think maybe some crud got dislodged. Having it looked at while im on vacation and not riding it would be ideal!
ronandkat is offline   Reply With Quote
Old 04-10-2013, 05:48 PM   #4
Prior
Gnarly Adventurer
 
Joined: Aug 2005
Location: Piedmont Triad, NC
Oddometer: 400
I had my Uly in GSO Harley for a warranty repair and they messed up more than they fixed. Never again. I turn my own wrenches as well, but good to know about the shop in Clemmons!

Certainly if you need some help with the bike, there are a few of us around that can help out.

Prior
Prior is offline   Reply With Quote
Old 04-10-2013, 06:06 PM   #5
ronandkat OP
Gnarly Adventurer
 
Joined: Sep 2007
Location: Greensboro NC
Oddometer: 147
I called the shop in clemmons and he gave me a little history lesson on his involvement with Buell.. I feel a bit better.

Id like to tackle it myself, Im just not knowledgable enough about hs antiquated system that is a buell powerplant to have confidence in my ability. I swear if it wasnt for pushrods and lifters it would need a valve adjustnt, based on the sound. BUt its only at the 2500-3000 rpm range, and ONLy with light throttle, anyhting more and it goes away... higher up the rm range it goes away. Runs perfect though.
ronandkat is offline   Reply With Quote
Old 04-10-2013, 06:39 PM   #6
KingJarhead
Beastly Adventurer
 
KingJarhead's Avatar
 
Joined: Apr 2011
Location: Not at Work...Pinnacle, NC
Oddometer: 1,901
Hope it works out.
Do you mind sharing his history?
__________________
--------------------------------------------
"There are 2 types of motorcycle riders, those that have wrecked and those that will wreck" - My Dad
KingJarhead is offline   Reply With Quote
Old 04-11-2013, 03:32 AM   #7
wb57
Beastly Adventurer
 
wb57's Avatar
 
Joined: Oct 2009
Location: Central NC
Oddometer: 6,430
Longshot:
You said it started immediately after an oil change. I had a truck that was particular about NOT using one brand of oil. Any chance this was a different oil than you normally use? Do a quick oil change with another oil and see if it goes away?
__________________
'10 Kawasaki Concours (EB)
'11 Kawasaki Versys

Turning money into spent fossil fuels.
(Smiley crap is implied in all posts.)
wb57 is offline   Reply With Quote
Old 04-11-2013, 04:28 AM   #8
ronandkat OP
Gnarly Adventurer
 
Joined: Sep 2007
Location: Greensboro NC
Oddometer: 147
Quote:
Originally Posted by KingJarhead View Post
Hope it works out.
Do you mind sharing his history?
He Owned a Harley shop, and brought buell on board and got pretty heavily into them. Was one of the first Buell techs in the state. Developed a race team / bike before buell eventually got yanked away and he went into business on his own as a bike shop. That's my understanding anyway.
It was kinda nice hearing " I can pretty much do anything to a buell you want done" Instead of the normal " well we don't really service those much anymore, yadda yadda"
ronandkat is offline   Reply With Quote
Old 04-11-2013, 04:30 AM   #9
ronandkat OP
Gnarly Adventurer
 
Joined: Sep 2007
Location: Greensboro NC
Oddometer: 147
Quote:
Originally Posted by wb57 View Post
Longshot:
You said it started immediately after an oil change. I had a truck that was particular about NOT using one brand of oil. Any chance this was a different oil than you normally use? Do a quick oil change with another oil and see if it goes away?
I used the Harley synthetic oil, but I did not change the filter when I changed it, because supposedly it was changed about 500 miles before I picked up the bike. Im thinking as a quick change maybe throwing some mobil 1 20w50 in there just because its a hell of a lot cheaper than the Harley stuff and see if it changes any.
ronandkat is offline   Reply With Quote
Old 04-12-2013, 07:43 PM   #10
Dukerdr
New old guy
 
Dukerdr's Avatar
 
Joined: Jan 2013
Location: McKenzie, Tn
Oddometer: 127
Sounds like pre-detonation to me.

Try a tank full of high test and see if it goes away.


Don't know why it would suddenly start after an oil change, usually this will
pop up after a change in the intake or exhaust system. Like a K+N air filter or a
free flowing muffler, without rejetting or re-mapping.


.
Dukerdr is offline   Reply With Quote
Old 04-16-2013, 11:46 AM   #11
ronandkat OP
Gnarly Adventurer
 
Joined: Sep 2007
Location: Greensboro NC
Oddometer: 147
I was curious about predetonation also, but it runs very well? However it still could be. Im thinking, I had it remapped, and then a week later I changed the oil. So chances I didn't notice the sound really in that week prior to changing the oil, because it has to be in a specific low rpm place or you don't hear it.. Maybe your on to something.
ronandkat is offline   Reply With Quote
Old 05-12-2013, 12:23 PM   #12
KingJarhead
Beastly Adventurer
 
KingJarhead's Avatar
 
Joined: Apr 2011
Location: Not at Work...Pinnacle, NC
Oddometer: 1,901
Ever find out what was wrong?
__________________
--------------------------------------------
"There are 2 types of motorcycle riders, those that have wrecked and those that will wreck" - My Dad
KingJarhead is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 12:52 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014