ADVrider

Go Back   ADVrider > Bikes > Old's Cool > 2 smokers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-12-2014, 12:47 PM   #1
Z_Silas OP
Adventurer
 
Z_Silas's Avatar
 
Joined: Sep 2013
Oddometer: 20
Cool2 My First Bike: 1980 Suzuki TS100

I've been asked a few times to post some picture of my old Suzuki so here it is. I bought my first bike in the summer of 2013, a lightly used 1980 Suzuki TS100 with 5.6k miles on the clock. I confess that I had actually been searching for a moped on craigslist when I found it. I called and the next day I drove my girlfriend's van home with a bike in the back! Days later I headed to the DMV and not only did I manage to pass the tests after crashing while weaving through the cones, but I also left with a unrestricted class M licence (as opposed to the 150cc or less class L that I was expecting). That was a good day.



A quick photo-shoot after I brought it home.

A quick photo-shoot after I brought it home.

A quick photo-shoot after I brought it home.

A nice fishing trip.

My first crash claimed the life of my fishing pole so I never actually went fishing.


Notice that the rod is missing a reel now


The exhaust had a nasty habit of rusting in a matter of minutes. Oh well, it least its clean on the inside.

A few miles later.

A current generation Suzuki (photo by 'Wallrat'). That spedometer looks familiar.....

How do you like my homemade rack?

How do you like my homemade rack?

That is an engine. And a carburetor, which always maintains a thin layer of oil.... to prevent rust of course.

Ever spray a coat of polyurethane on your seat?

Notice the folding passenger pegs. Yes this is a wonderful bike for riding 2up.

I didn't wear my helmet this time, but I brought it.....just in case.

Ah I love dragging that quart of 2-stroke oil around everywhere. I also love doing the math at the gas station and the look some people give you after you add the oil and start shaking the bike up.

Lake ?



The Merrimack River

The Merrimack River

St. Joe's State Park - A great place to ride

St. Joe's State Park - A great place to ride

A picture taken right before I had the best adventure ever!
Here's the link to that http://advrider.com/forums/showthread.php?t=924316

Three of my rides. I got a 2014 Honda CFR250L this year and since I only have room for one bike, I sent my Suzuki to live with my parents... three hours away at least it gets a garage now.
Z_Silas is offline   Reply With Quote
Old 02-12-2014, 04:26 PM   #2
Edmond Dantès
The Kanto Pain
 
Edmond Dantès's Avatar
 
Joined: Jul 2009
Location: Château d'If
Oddometer: 580
Thanks for posting. I remember reading your RR months and months ago, and requesting you post more pics of your ER. I gave up hope of seeing more pics, and then you go spring this on me!

My first road legal bike was an ER50. Same color as your 100. Boy, did I look forward to my 16th birthday so as I could ride off into the drizzling rain of the Berkshire countryside!

Quote:
Ah I love dragging that quart of 2-stroke oil around everywhere. I also love doing the math at the gas station and the look some people give you after you add the oil and start shaking the bike up.
Say what? Someone must have dismantled the autolub system?

Thanks for posting. These pictures bring back memories of 30 years past.
Edmond Dantès is offline   Reply With Quote
Old 02-12-2014, 07:15 PM   #3
R0ACH1NGT0N
n00b
 
R0ACH1NGT0N's Avatar
 
Joined: Feb 2014
Location: Duluth, MN
Oddometer: 6
Sweet bike, looks like its in great condition!
R0ACH1NGT0N is offline   Reply With Quote
Old 02-17-2014, 02:40 AM   #4
Bucho
Beastly Adventurer
 
Joined: Dec 2006
Location: Maryland
Oddometer: 1,741
That such a cool little bike!

I would love to pick up something like that.
Bucho is offline   Reply With Quote
Old 02-19-2014, 03:45 PM   #5
Z_Silas OP
Adventurer
 
Z_Silas's Avatar
 
Joined: Sep 2013
Oddometer: 20
Quote:
Originally Posted by Edmond Dantès View Post
Thanks for posting. I remember reading your RR months and months ago, and requesting you post more pics of your ER. I gave up hope of seeing more pics, and then you go spring this on me!

My first road legal bike was an ER50. Same color as your 100. Boy, did I look forward to my 16th birthday so as I could ride off into the drizzling rain of the Berkshire countryside!



Say what? Someone must have dismantled the autolub system?

Thanks for posting. These pictures bring back memories of 30 years past.
You Inspired me to post more photos. Just took a little bit. Yeah... autolube was gone when I got it. Although I have heard stories of these clogging up and locking up the engine.
Z_Silas is offline   Reply With Quote
Old 02-22-2014, 08:02 AM   #6
vtwin
Air cooled runnin' mon
 
vtwin's Avatar
 
Joined: Jan 2005
Location: NorCal
Oddometer: 7,117
Quote:
Originally Posted by Z_Silas View Post
You Inspired me to post more photos. Just took a little bit. Yeah... autolube was gone when I got it. Although I have heard stories of these clogging up and locking up the engine.

Isn't the autolube for injecting into the rods and crank as well? I believe my K11p and Stinger is that way. My M35 used premix though.

__________________
"Alles hat ein Ende--nur die Wurst, sie hat zwei"
Monroe.

"You only have too much fuel if you're on fire"
unknown
vtwin is offline   Reply With Quote
Old 02-24-2014, 05:28 PM   #7
Z_Silas OP
Adventurer
 
Z_Silas's Avatar
 
Joined: Sep 2013
Oddometer: 20
Quote:
Originally Posted by vtwin View Post
Isn't the autolube for injecting into the rods and crank as well? I believe my K11p and Stinger is that way. My M35 used premix though.

I'm not sure. But I've gotten 7000 miles without so I couldn't have caused too much damage. Also I think the 400 mile oil changes keep things from getting too dry.
Z_Silas is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 11:00 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014