ADVrider

Go Back   ADVrider > Riding > Layin' down tracks
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-14-2013, 01:49 PM   #1
Old Nuke OP
Flatlander
 
Old Nuke's Avatar
 
Joined: Jun 2005
Location: Near the shores of Big Muddy
Oddometer: 219
Missing Power ON/Off Button

The power on/off rubber button on my Zumo 550 came off/disappeared. Is this a common problem and do the sell replacement ones anywhere?
Old Nuke is offline   Reply With Quote
Old 12-02-2013, 09:06 PM   #2
ADVer
Gnarly Adventurer
 
ADVer's Avatar
 
Joined: Nov 2006
Location: Pittsburgh, PA
Oddometer: 187
See here
http://http://advrider.com/forums/showthread.php?t=795635
__________________
ADVer
ADVer is offline   Reply With Quote
Old 12-03-2013, 12:03 AM   #3
Loui€
Rides With Reindeer
 
Loui€'s Avatar
 
Joined: May 2012
Location: PoroWaara
Oddometer: 43
I did it my way:

http://www.advrider.com/forums/showp...&postcount=197

L
__________________
2008 KTM 990 ADV
Loui€ is offline   Reply With Quote
Old 12-03-2013, 06:00 AM   #4
Old Nuke OP
Flatlander
 
Old Nuke's Avatar
 
Joined: Jun 2005
Location: Near the shores of Big Muddy
Oddometer: 219
I did something similar with some tape. Thanks for your repair tip though. I have already purchased a new BMW Nav V to replace the 550, but, I want to keep using the 550 on a second bike. The 550 still performs like new. Any used 550 cases or junk 550s out there?
Old Nuke is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:51 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014