ADVrider

Go Back   ADVrider > Bikes > Orange Crush > Crazy-Awesome almost Dakar racers (950/990cc)
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-28-2014, 03:09 PM   #1
NeptuneTriton OP
Gnarly Adventurer
 
Joined: May 2013
Oddometer: 195
KTM 990 Adventure Faulty Ignition Wiring - Don't Get Stranded, Check Your Bikes!!

DON'T GET STRANDED IN THE MIDDLE OF NOWHERE, CHECK YOUR BIKES!


Hello All! I wanted to post this summary and a video review of what I believe is a common problem with the 990 Adventure Series. I did a search and found multiple other riders experiencing something very similar and I think I've found the root cause.

I just experienced the exact same thing on my new 990 Baja. It has about 1,200 miles on it and it kept dying out randomly. At first I thought it was my kickstand safety switch or clutch safety switch acting up, but after some investigation they appeared to be fine.

I then noticed it seemed to happen depending on handlebar position. As I moved the bar from right to left, just past the center line, the bike would die out. So I knew it had to be something to do with the wiring by the bars. After some more investigation, I found it to be the ignition wiring harness.

The black plastic cosmetic cover on the right side of the bike, just behind the steering head bearing, has no provision to allow the ignition wire to move freely. It needs to be trimmed to allow the ignition wire harness to move freely and not get pinched against the frame. Adding to that, it was fastened so tightly that it was pressing the ignition harness against the frame of the bike. Because the harness could not move with the handlebars, it would flex in two points over and over and over again....leading to breakage in the wiring. This would immediately kill the engine. I'm lucky I found this while I was close to home and not out on a trail somewhere!! KTM needs to address this issue ASAP as I see a lot of other posts about the same thing.










[/QUOTE]

NeptuneTriton screwed with this post 03-06-2014 at 08:15 AM
NeptuneTriton is offline   Reply With Quote
Old 02-28-2014, 03:13 PM   #2
NeptuneTriton OP
Gnarly Adventurer
 
Joined: May 2013
Oddometer: 195
Ignition Wiring Installation Video

I made a video about it and uploaded it to YouTube for further clarification. Hopefully this will help anyone else experiencing the same problem find a solution quickly.


https://www.youtube.com/watch?v=2q6ym8ZdC-Q


While I was at the dealer yesterday submitting the warranty claim, I decided to check the new 990 Baja they had sitting on the showroom floor. Sure enough, same problem. The black plastic cover was pinching the ignition harness against the frame as well...so it's just a matter of time before the same thing happens to that bike as well.

NeptuneTriton screwed with this post 03-02-2014 at 05:29 AM
NeptuneTriton is offline   Reply With Quote
Old 02-28-2014, 03:26 PM   #3
NeptuneTriton OP
Gnarly Adventurer
 
Joined: May 2013
Oddometer: 195
Other threads with similar problems....

Last but not least, in my research, I found some other people having the same issues. Some think it's because they've installed risers, other because of how the wiring is made, but I honestly think most of them are caused by the ignition harness getting pinched from the factory.

http://www.advrider.com/forums/showthread.php?t=934940

http://www.advrider.com/forums/showthread.php?t=750127

http://www.advrider.com/forums/showthread.php?t=264688

http://www.advrider.com/forums/showthread.php?t=537448

http://advrider.com/forums/showthread.php?t=942420

http://www.advrider.com/forums/showthread.php?t=315746

http://www.advrider.com/forums/showthread.php?t=926540
NeptuneTriton is offline   Reply With Quote
Old 02-28-2014, 03:39 PM   #4
Night Falcon
Adventure NZL
 
Night Falcon's Avatar
 
Joined: Dec 2008
Location: Nu Va Ze Lon
Oddometer: 1,766
I am a big KTM fan but I have to say the wiring on some of their bikes is below par.
__________________
2010 KTM EXC 530
2008 Beta Rev3
Night Falcon is offline   Reply With Quote
Old 02-28-2014, 03:45 PM   #5
_cy_
Beastly Adventurer
 
Joined: Sep 2011
Location: Tulsa, Oklahoma
Oddometer: 5,941
NTSB should know about this .. they could force a recall since this easily could be a safety issue having your engine die pulling out into fast traffic.
_cy_ is offline   Reply With Quote
Old 02-28-2014, 04:08 PM   #6
NeptuneTriton OP
Gnarly Adventurer
 
Joined: May 2013
Oddometer: 195
And another guy just had this problem...on a 990 SMT. So it appears the issue isn't isolated to the 990 ADV lineup.

http://advrider.com/forums/showthread.php?t=956481

I agree that KTM needs to address this and maybe issue a recall. My bike died on me in rush hour traffic this week which is dangerous.

Maybe we should make this a sticky to see how many others are out there? Or at least make sure people know to check this in addition to the usual "my bike is cutting out" suspect list of kickstand and clutch safety switches gone awry.
NeptuneTriton is offline   Reply With Quote
Old 02-28-2014, 04:58 PM   #7
Rodknee
I wish I was Ghetto
 
Rodknee's Avatar
 
Joined: Apr 2010
Location: new friggin york
Oddometer: 2,214
thanks for the post Neptune, although i did not have any issues with my bike, i will check my bike before talking it out again. Thank you sir!
__________________
Quote:
Originally Posted by JustRon View Post
my ass was jealous of Rodney's day-long-ass.
NY to Alaska Ride Report Aug 14'
2014 Rides: Katie M Big girl & Berg Hoon'icycle
RIP Buddy 1999-2014
Rodknee is offline   Reply With Quote
Old 02-28-2014, 11:26 PM   #8
DirtyADV
Beastly Adventurer
 
DirtyADV's Avatar
 
Joined: Jan 2007
Location: SWEDEN, Skellefteå
Oddometer: 2,122
Saw it as an issue also on my brand new 990R while adding some wiring for heated grips and some extra lights, trimmed some plastic away on the lower front part similar to how the other side is opened to allow the wiring on that side to pass easily:



/Johan
__________________
Have changed name, was previously Dirty950

www.dirtyadv.com (under construction)
DirtyADV is online now   Reply With Quote
Old 03-01-2014, 05:38 AM   #9
Apple Jam
Forest Flyer
 
Apple Jam's Avatar
 
Joined: Aug 2007
Location: Mt Hood mud flow
Oddometer: 6,330
Yep. It got me, too, exactly as you describe. Wire was broken inside the still good insulation for me. It looked just fine, and was a bitch to track down until I got my meter out to check continuity.
__________________
..
"got no problem with keeping truly roadless areas as wild....
On the other hand, if it has been logged or mined and roads already exist,,
...then that land should be open for public use" (peterman)
Apple Jam is offline   Reply With Quote
Old 03-01-2014, 08:07 AM   #10
Knobbiethrower
ADV in ADK
 
Knobbiethrower's Avatar
 
Joined: Nov 2005
Location: Where I am
Oddometer: 1,219
Just checked mine,it's in the same condition as pictured. Currently on the to do list to get fixed.
Knobbiethrower is offline   Reply With Quote
Old 03-01-2014, 09:15 AM   #11
JohnnyWaffles
Gnarly Adventurer
 
Joined: Jul 2012
Location: Denver, CO
Oddometer: 238
Thanks for the pictures and detailed description, seriously. I've been tracking everyone elses similar issues and I'm thrilled this is now documented and easily preventable. It's disappointing on KTM's part, especially since I have the last model year and it's still an issue.
__________________
2013 KTM 990 Adventure Baja Edition
Quote:
Originally Posted by Beefeater Steve
The KTM is the kind of bike you take behind the middle school and get pregnant. It's the kind of bike that, from the moment you light the fire, you know is downright nasty and makes you want to meet in the Burger King bathroom and lick its butthole.
JohnnyWaffles is offline   Reply With Quote
Old 03-01-2014, 10:37 AM   #12
tacosupreme
Gnarly Adventurer
 
tacosupreme's Avatar
 
Joined: Mar 2013
Location: Pendleton, Oregon
Oddometer: 257
Just checked my 2012 dakar. Mine still worked, no problems yet but there was bare wire showing and it wouldn't have lasted long. So far, my new bike came from the dealer with smashed 02 sensor wires under the crash bars, an oil leak on the front cam chain tensioner, fuel line with a hole in it, and faulty ignition wires. Let's hope that's it. EDIT: I just repaired the wires, heat shrink and wire loom on the entire length, and threw away the covers.
__________________
'12 990 with some orange stuff on it to make it go faster.

tacosupreme screwed with this post 03-01-2014 at 04:06 PM
tacosupreme is offline   Reply With Quote
Old 03-01-2014, 04:17 PM   #13
Duas Rodas
Adventurer
 
Duas Rodas's Avatar
 
Joined: Nov 2011
Oddometer: 98
I like to thank the original poster. Thanks Neptune
Most likely I would eventually ended up stranded somewhere because of this Just a matter of time...

Here is what mine looks like.








I too am disapointed with KTM's wire routing issues!
The bike is now on it's third Wheel Speed Sensor!!!! The original and first replacement were broken due to the wire being pulled when the handled bars were moved through from lock to lock. Bad routing and real stupid use of zip-ties was the culprid (twice)
The bike only has about 9,000km I think (both times I was on multi day trips and lost track of the mileage), so it's kind of ridiculous, isn't it?

I have to find some pictures now...and start another thread on an alarming fuel line incident...

Oh yeah, I still love the "Burra Branca". She's fun...
Duas Rodas is offline   Reply With Quote
Old 03-01-2014, 04:36 PM   #14
GJ990
Gnarly Adventurer
 
GJ990's Avatar
 
Joined: Mar 2013
Location: Central Florida
Oddometer: 254
Just checked mine. Same problem, can I just remove the black plastic thingy?
__________________
990 Baja
GJ990 is offline   Reply With Quote
Old 03-01-2014, 05:19 PM   #15
speedy 1
Wizard
 
Joined: Jan 2013
Location: 100km north of the Golden Gate
Oddometer: 8
Thanks for the heads up
Looks like my bike will need some attention
speedy 1 is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 03:32 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014